Back to overview
Degraded

Text Messaging is slow

Nov 04 at 09:44am PST
Affected services
Email & text messaging, pre July 2025 Implementation
Email & text messaging, post July 2025 Implementation

Resolved
Nov 04 at 12:30pm PST

Twilio has resolved the issue. We will continue to monitor.

Updated
Nov 04 at 10:37am PST

Twilio has found the issue and is implementing a fix.

Created
Nov 04 at 09:44am PST

We are aware of disruptions with Twilio that is affecting some or all of our election partner's text messaging delivery.

We are monitoring the issue closely.