Back to overview
Maintenance

System maintenance

Jun 5, 2026 at 3:00am UTC  –  Jun 5, 2026 at 3:14am UTC
Affected services
Email & text messaging, pre July 2025 Implementation
Worker pool

Resolved
Jun 5, 2026 at 3:14am UTC

Maintenance ended

Updated
Jun 5, 2026 at 3:14am UTC

Maintenance is complete and all partners are up and running.

Updated
Jun 5, 2026 at 3:03am UTC

Maintenance has started and all partner's bases are now up-to date with the latest backend.

Created
Jun 5, 2026 at 3:00am UTC

USDR is performing some maintenance on our legacy messaging platform. We do not expect any downtime during this maintenance window.